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Chapter 14 JavaFX Basics
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Using JavaFX in Eclipse

Download an appropriate JavaFX runtime (https://gluonhq.com/products/javafx/ )for your operating system and unzip 

it to a desired location. Put the contents of this zip file somewhere on your system, for example in 

“C:\Users\selim\Documents\javafx-sdk-11.0.2\”. 

METHOD I:

Install the JavaFx plug-in for eclipse.  

- With Eclipse open, click Help > Install New Software…

- Click the Add… button.

- Enter a name, such as JavaFX.

- Enter the location as follows:  http://download.eclipse.org/efxclipse/updates-released/1.2.0/site/ 

- Check both options “e(fx)clipse – install” and “e(fx)clipse – single components” as shown.  Accept other defaults.  

Click the Next button.

- These are the items that will be installed.  Click Next again.

- Accept terms and click Finish.

- You’ll be prompted to reboot Eclipse.  The plug-in is now installed and is ready to use.

File -> Properties -> Java Build Path -> Libraries tab -> Add external jars

select and include all files in the directory that has unzipped files (for example “C:\Users\selim\Documents\javafx-

sdk-11.0.2\lib”)

Now, to use JavaFx...

- Navigate to File > New > Project

- In the New Project wizard, select JavaFx > JavaFX Project

- Enter a name for the project, ie, JavaFxDemo, etc.  Click Finish.

- Go to the project name > src > application.  Click once on application to highlight.  Create classes here (right-mouse 

click, New > Class)
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METHOD II:

- File -> Properties -> Java Build Path -> Libraries tab -> Add external jars

- select and include all files in the directory that has unzipped files (for example

“C:\Users\selim\Documents\javafx-sdk-11.0.2\lib”)

- Windows -> Preferences -> Java -> Installed JREs -> Edit

- Put 

--module-path "C:\Users\selim\Documents\javafx-sdk-11.0.2\lib" --add-modules

javafx.controls,javafx.fxml,javafx.graphics,javafx.media

- in Default VM Arguments. Note that your JavaFX library location can be different depending on the

location that you unzipped.

METHOD III:

From CMD Prompt:

java --module-path "C:\Users\selim\Documents\javafx-sdk-11.0.2\lib" --add-modules javafx.controls

BounceBallControl
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Motivations

▪ JavaFX is a new framework for developing Java 
GUI programs. The JavaFX API is an excellent 
example of how the object-oriented principle is 
applied. 

▪ This chapter serves two purposes. First, it presents 
the basics of JavaFX programming. Second, it uses 
JavaFX to demonstrate OOP. Specifically, this 
chapter introduces the framework of JavaFX and 
discusses JavaFX GUI components and their 
relationships. 
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Objectives
❑ To distinguish between JavaFX, Swing, and AWT (§14.2).

❑ To write a simple JavaFX program and understand the relationship among stages, 

scenes, and nodes (§14.3).

❑ To create user interfaces using panes, UI controls, and shapes (§14.4).

❑ To use binding properties to synchronize property values (§14.5).

❑ To use the common properties style and rotate for nodes (§14.6).

❑ To create colors using the Color class (§14.7).

❑ To create fonts using the Font class (§14.8).

❑ To create images using the Image class and to create image views using the 

ImageView class (§14.9).

❑ To layout nodes using Pane, StackPane, FlowPane, GridPane, BorderPane, HBox, 

and VBox (§14.10).

❑ To display text using the Text class and create shapes using Line, Circle, Rectangle, 

Ellipse, Arc, Polygon, and Polyline (§14.11).

❑ To develop the reusable GUI components ClockPane for displaying an analog clock 

(§14.12).
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JavaFX vs Swing and AWT

▪ Swing and AWT are replaced by the JavaFX platform for 
developing rich Internet applications.

▪ When Java was introduced, the GUI classes were bundled in a 
library known as the Abstract Windows Toolkit (AWT). 

▪ AWT is fine for developing simple graphical user interfaces, 
but not for developing comprehensive GUI projects. In 
addition, AWT is prone to platform-specific bugs. 

▪ The AWT user-interface components were replaced by a more 
robust, versatile, and flexible library known as Swing
components. Swing components are painted directly on 
canvases using Java code. 

▪ Swing components depend less on the target platform and use 
less of the native GUI resource. With the release of Java 8, 
Swing is replaced by a completely new GUI platform known 
as JavaFX. 
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Basic Structure of JavaFX

▪ Application

▪ Override the start(Stage) method

▪ Stage, Scene, and Nodes

 Stage 

Scene 

Button 

MyJavaFX Run

▪A JavaFX GUI Program extends from 

javafx.application.Application (just 

like a Java Swing GUI program 

extends from javax.swing.JFrame).

▪JavaFX names the Stage and Scene

classes using the analogy from the 

theater. 

▪You may think of stage as the 

platform to support scenes, and nodes 

as actors to perform in the scenes.

https://liveexample.pearsoncmg.com/html/MyJavaFX.html
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▪ The launch method (line 22) is a static method 

defined in the Application class for launching a 
stand-alone JavaFX application. 

▪ The main method (lines 21–23) is not needed if 
you run the program from the command line. It 
may be needed to launch a JavaFX program from 
an IDE with a limited JavaFX support. When you 
run a JavaFX application without a main method, 
JVM automatically invokes the launch method to 
run the application.

▪ The main class overrides the start method defined 
in javafx.application.Application (line 8). 
After a JavaFX application is launched, the JVM 
constructs an instance of the class using its no-arg
constructor and invokes its start method. 

▪ The start method normally places UI controls in a 
scene and displays the scene in a stage. 

▪ Line 10 creates a Button object and places it in a 
Scene object (line 11). A Scene object can be 
created using the constructor Scene(node, 
width, height). This constructor specifies the 
width and height of the scene and places the node 
in the scene.

8
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Basic Structure of JavaFX

▪ A Stage object is a window. A Stage object called primary 
stage is automatically created by the JVM when the application 
is launched.

▪ Line 13 sets the scene to the primary stage and line 14 displays 
the primary stage. 

▪ JavaFX names the Stage and Scene classes using the analogy 
from the theater. 

▪ You may think of stage as the platform to support scenes, and 
nodes as actors to perform in the scenes.

▪ You can create additional stages if needed. The JavaFX program 
in Listing 14.2 displays two stages, as shown in Figure 14.2b.

9

MultipleStageDemo Run

https://liveexample.pearsoncmg.com/html/MultipleStageDemo.html
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1.JavaFX uses the metaphor of a theater to model the graphics application. A stage (defined by 
the javafx.stage.Stage class) represents the top-level container (window). The individual controls (or 

components) are contained in a scene (defined by the javafx.scene.Scene class). An application can 

have more than one scenes, but only one of the scenes can be displayed on the stage at any given time. 

The contents of a scene is represented in a hierarchical scene graph of nodes (defined 
by javafx.scene.Node).

2.To construct the UI:

1.Prepare a scene graph.

2.Construct a scene, with the root node of the scene graph.

3.Setup the stage with the constructed scene.
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Panes, UI Controls, and Shapes

ButtonInPane Run

https://liveexample.pearsoncmg.com/html/ButtonInPane.html
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Display a Shape

This example displays a circle in the center of the pane.

 

(0, 0) X Axis 

Y Axis 

(x, y) 

   

x 

  y 

Java 

Coordinate 

System 

X Axis 

Conventional 

Coordinate  
System 

(0, 0) 

Y Axis 

ShowCircle Run

https://liveexample.pearsoncmg.com/html/ShowCircle.html
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Binding Properties

▪ JavaFX introduces a new concept called binding 

property that enables a target object to be bound to a 

source object. 

▪ If the value in the source object changes, the target 

property is also changed automatically. 

▪ The target object is simply called a binding object or a 

binding property. 

ShowCircleCentered Run

https://liveexample.pearsoncmg.com/html/ShowCircleCentered.html
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Binding Property:

getter, setter, and property getter
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Uni/Bidirectional Binding

BidirectionalBindingDemo Run

BindingDemo Run

https://liveexample.pearsoncmg.com/html/BidirectionalBindingDemo.html
https://liveexample.pearsoncmg.com/html/BindingDemo.html
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Common Properties and Methods 

for Nodes 
▪ JavaFX style properties are similar to cascading style sheets (CSS) used to specify the styles 

for HTML elements in a Web page. Therefore, the style properties in JavaFX are called 
JavaFX CSS. 

▪ In JavaFX, a style property is defined with a prefix –fx–. Each node has its own style 
properties. 

▪ You can find these properties at docs.oracle.com/javafx/2/api/javafx/scene/doc-
files/cssref.html.

▪ The syntax for setting a style is styleName:value. 

▪ Multiple style properties for a node can be set together separated by semicolon (;). For 
example, the following statement:

circle.setStyle("−fx−stroke: black; −fx−fill: red;");

▪ This statement is equivalent to the following two statements:

circle.setStroke(Color.BLACK);

circle.setFill(Color.RED);

▪ rotate: Rotate a node

NodeStyleRotateDemo Run

https://liveexample.pearsoncmg.com/html/NodeStyleRotateDemo.html
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The Color Class
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The Font Class

FontDemo Run

https://liveexample.pearsoncmg.com/html/FontDemo.html
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The Image Class
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The ImageView Class

ShowImage Run

https://liveexample.pearsoncmg.com/html/ShowImage.html
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Layout Panes

JavaFX provides many types of panes for organizing nodes 

in a container.
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FlowPane

MultipleStageDemo Run

https://liveexample.pearsoncmg.com/html/ShowFlowPane.html
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GridPane

ShowGridPane

Run

https://liveexample.pearsoncmg.com/html/ShowGridPane.html
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BorderPane

ShowBorderPane Run

https://liveexample.pearsoncmg.com/html/ShowBorderPane.html
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HBox
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VBox

ShowHBoxVBox Run

https://liveexample.pearsoncmg.com/html/ShowHBoxVBox.html
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Shapes
JavaFX provides many shape classes for drawing texts, 

lines, circles, rectangles, ellipses, arcs, polygons, and 

polylines.
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Text
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Text Example

ShowText Run

https://liveexample.pearsoncmg.com/html/ShowText.html
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Line

ShowLine Run

https://liveexample.pearsoncmg.com/html/ShowLine.html
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Rectangle
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Rectangle Example

ShowRectangle Run

https://liveexample.pearsoncmg.com/html/ShowRectangle.html
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Circle



Liang, Introduction to Java Programming, Eleventh Edition, (c) 2018 Pearson Education, Ltd. 

All rights reserved. 
37

Ellipse

 

(centerX, centerY) 
 

 

radiusY 
 

 

radiusX 
 

 

ShowEllipse Run

https://liveexample.pearsoncmg.com/html/ShowEllipse.html


Liang, Introduction to Java Programming, Eleventh Edition, (c) 2018 Pearson Education, Ltd. 

All rights reserved. 
38

Arc
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Arc Examples
 

(centerX, centerY) 
 

radiusX 
 

 

radiusY 
 

 

length 
 

 startAngle 
 

 0 degree 
 
 

 

(a) Negative starting angle –30° and 

negative spanning angle –20° 
(b) Negative starting angle –50° 

and positive spanning angle 20° 

–30° 

–20° 

–50° 

20° 

ShowArc Run

https://liveexample.pearsoncmg.com/html/ShowArc.html
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Polygon and Polyline
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Polygon
 

javafx.scene.shape.Polygon 

+Polygon() 

+Polygon(double... points) 

+getPoints(): 

ObservableList<Double> 

 

Creates an empty polygon. 

Creates a polygon with the given points. 

Returns a list of double values as x- and y-coordinates of the points. 

 

The getter and setter methods for property values and a getter for property 

itself are provided in the class, but omitted in the UML diagram for brevity. 
  
 

ShowPolygon Run

https://liveexample.pearsoncmg.com/html/ShowPolygon.html
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Case Study: The ClockPane Class
This case study develops a class that displays a clock on a 

pane.

 

ClockPane 
 

-hour: int 

-minute: int 

-second: int 

+ClockPane() 

+ClockPane(hour: int, minute: int, 

second: int) 

+setCurrentTime(): void 

+setWidth(width: double): void 

+setHeightTime(height: double): void 

 

javafx.scene.layout.Panel 
 
-char token 
 
+getToken 
+setToken 
+paintComponet 
+mouseClicked 

 

The getter and setter methods for 

these data fields are provided in the class, 
but omitted in the UML diagram for brevity. 
  
 

The hour in the clock. 

The minute in the clock. 

The second in the clock. 

Constructs a default clock for the current time. 

Constructs a clock with the specified time. 

Sets hour, minute, and second for current time. 
Sets clock pane’s width and repaint the clock, 

Sets clock pane’s height and repaint the clock, 

 
ClockPane

https://liveexample.pearsoncmg.com/html/ClockPane.html
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Use the ClockPane Class

DisplayClock Run

https://liveexample.pearsoncmg.com/html/DisplayClock.html

